コードを綺麗に表示する highlight.js

もともとgoogle code prettifyを使っていたのですが、なんとなく他のものを試していたら良さそうなのを見つけたので紹介。

highlightjs

highlightjs web

highlight.js

まずは、開いてlanguagestyleをポチポチしてみてください。どんな感じか解ると思います。

設定できるすべての項目が選べるわけではないので、「( ・∀・)イイ!!」と思ったなら
このページでいろいろ試してみるのがいいと思います。


Read more…

0 Comments
8月 10, 2014

CygwinでRuby 2.1.0をクロスコンパイル with Android NDK

ところどころ手を加える必要があったので備忘録をかねて。(Cygwinと書きましたがほかの環境でも参考になると思います。)

Cygwin (またはGNU/LinuxなどのNDKを動かせるもの) の導入

今回は省きます。と、言ってもほとんど初期状態でも大丈夫な気がしますが。
ただ、CygwinMSYS/MinGWなどのWindows上の環境でやるには管理者権限が必要です。
ビルドする際にシンボリックリンクを張りながら進むものがあってそれでとまります。NDKのツールが解釈できない模様。

echo "" >> ~/.zshrc
echo "export CYGWIN='dosfilewarning winsymlinks:native'" >> ~/.zshrc

などとしておくと好いでしょう。ただ、管理者権限で起動するとなぜかdosfilewarningが効かないのつらい。改めてsource ~/.zshrcとかexport CYGWIN=以下略とかすると大丈夫なんだけどね…


Read more…

0 Comments
2月 22, 2014

Apktoolの使い方(コマンドラインオプションの解説)

apktoolを導入してオプションなしで起動するとヘルプが表示されます。使い方が表示されるので1度目を通しておいた方がよいのですが英語となると尻込みしてしまう人が多いと思います。

そこで、この記事では日本語で解説(単に訳しただけとも言う;)することを目標にしています。

この記事ではapktoolは2013/01/12時点での最新版である1.5.1を導入済みであるとして解説していきます。

まず事前知識としてですが、使い方で「[]」に囲まれている部分は省略することができます。
また「|」はORを意味します。(どちらかということを意味します。)


Read more…

2 Comments
タグ: ,
1月 26, 2013

POBox 5.4をXperia以外の端末でも動くようにする。(root不要)

POBox 5.4で五十音キーボードと手書きの軌跡を有効化し、ソニーチェックを無効化した状態。

POBox 5.4はAndroid 4.1/JB 以上向けです。それ以下の端末では動作しません。(2.3/GB,2.2/CCなど)

ついでに言うと、POBoxがプリインストールの端末(Xperiaシリーズ)にも署名の関係でストレートにはインストール出来ません。残念ながらroot権限でシステムアプリとしてのJapaneseIME.apkとPOBoxSknSelector.apkを削除しておく必要がありますx(

※ただし、4.0/ICSはある手順を踏めば導入可能です。これに関しては、やや面倒なのでこの記事では扱いませんコメント欄にメモ程度にかいておきます。

※サイズ変更時のバグは解消されています。

 

前回、POBox 5.3をXperia以外の端末でも動くようにする。(root不要) この記事でPOBox5.3の導入を行った人は一部作業が重複するので適宜対処してください。(C:\Temp\POBoxを削除、一部作業を飛ばす等)


Read more…

84 Comments
1月 19, 2013

ステータスバーはそのままにナビゲーションバーだけを消す方法(要root、カスタムROM不要)

タイトルの通りですが、試して見ました。

System領域をいじるので文鎮()状態になる危険はありますが復旧は可能です。

(完全に文鎮になることはないと思います。たぶん。)

また、作業を行う際は自己責任でお願いします。

あ、あと基本的にはwindows向けの記事です。


Read more…

12月 29, 2012

POBox 5.3をXperia以外の端末でも動くようにする。(root不要)

POBox 5.3で五十音キーボードと手書きの軌跡を有効化し、ソニーチェックを無効化した状態。

すでに某所で公開しましたが、一応。ちなみにWindows向けです。

POBox 5.3はAndroid 4.0/ICS 以上向けです。それ以下の端末では動作しません。(2.3/GB,2.2/CCなど)

この記事でPOBox5.4について扱っています。タブレット向けレイアウトも追加されていますが、個人的にはタブレット向けにはPOBox5.3の方がいいと思います。


Read more…

12月 28, 2012